import re
regex = re.compile(r"\s+(?=[0-9]{2}\.[0-9]{4})", flags=re.MULTILINE)
test_str = "24.3483 stuff stuff 34.8325 some more stuff"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)