$re = '/\s+(?=[0-9]{2}\.[0-9]{4})/m';
$str = '24.3483 stuff stuff 34.8325 some more stuff';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;