#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Q)(?:\d+(?![.\d])|\d+\.\d+(?![.\d]))"
Local $sString = "Q232.1232 K1232.232323" & @CRLF & _
"Q232 K1232.232323" & @CRLF & _
"Q232.1232" & @CRLF & _
"K1232.2323 Q232.1232" & @CRLF & _
"R232.1232 K1232.232323" & @CRLF & _
"Q232.12.32 K1232.232323" & @CRLF & _
"Q232. K1232.232323"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")