$re = '/(?<=Q)(?:\d+(?![.\d])|\d+\.\d+(?![.\d]))/m';
$str = 'Q232.1232 K1232.232323
Q232 K1232.232323
Q232.1232
K1232.2323 Q232.1232
R232.1232 K1232.232323
Q232.12.32 K1232.232323
Q232. K1232.232323';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);