import Foundation
let pattern = #"(?<=Q)(?:\d+(?![.\d])|\d+\.\d+(?![.\d]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Q232.1232 K1232.232323
Q232 K1232.232323
Q232.1232
K1232.2323 Q232.1232
R232.1232 K1232.232323
Q232.12.32 K1232.232323
Q232. K1232.232323
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)