const regex = /(?<=Q)(?:\d+(?![.\d])|\d+\.\d+(?![.\d]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Q)(?:\\d+(?![.\\d])|\\d+\\.\\d+(?![.\\d]))', 'gm')
const str = `Q232.1232 K1232.232323
Q232 K1232.232323
Q232.1232
K1232.2323 Q232.1232
R232.1232 K1232.232323
Q232.12.32 K1232.232323
Q232. K1232.232323`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}