import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Q)(?:\\d+(?![.\\d])|\\d+\\.\\d+(?![.\\d]))";
final String string = "Q232.1232 K1232.232323\n"
+ "Q232 K1232.232323\n"
+ "Q232.1232\n"
+ "K1232.2323 Q232.1232\n"
+ "R232.1232 K1232.232323\n"
+ "Q232.12.32 K1232.232323\n"
+ "Q232. K1232.232323";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}