using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Q)(?:\d+(?![.\d])|\d+\.\d+(?![.\d]))";
string input = @"Q232.1232 K1232.232323
Q232 K1232.232323
Q232.1232
K1232.2323 Q232.1232
R232.1232 K1232.232323
Q232.12.32 K1232.232323
Q232. K1232.232323";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}