import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z|\\u0400-\\u042F])(?=.*[a-z|\\u0430-\\u044f])(?=.*[\\d])(?=.*[!@#$%^&*.])[\\u0400-\\u04FF\\d\\w!@#$%^&*.]{8,70}$";
final String string = "2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}