import Foundation
let pattern = ##"^(?=.*[A-Z|\u0400-\u042F])(?=.*[a-z|\u0430-\u044f])(?=.*[\d])(?=.*[!@#$%^&*.])[\u0400-\u04FF\d\w!@#$%^&*.]{8,70}$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)