$re = '/^(?=.*[A-Z|\u0400-\u042F])(?=.*[a-z|\u0430-\u044f])(?=.*[\d])(?=.*[!@#$%^&*.])[\u0400-\u04FF\d\w!@#$%^&*.]{8,70}$/';
$str = '2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);