re = /^(?=.*[A-Z|\u0400-\u042F])(?=.*[a-z|\u0430-\u044f])(?=.*[\d])(?=.*[!@#$%^&*.])[\u0400-\u04FF\d\w!@#$%^&*.]{8,70}$/
str = '2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end