#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[01]?[0-9]{1,2}(?:\.[0-9]+)?$"
Local $sString = "0.0" & @CRLF & _
"50.123" & @CRLF & _
"150.103" & @CRLF & _
"199.99" & @CRLF & _
"200" & @CRLF & _
"200.00" & @CRLF & _
"200.01" & @CRLF & _
"205.111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")