import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[01]?[0-9]{1,2}(?:\\.[0-9]+)?$";
final String string = "0.0\n"
+ "50.123\n"
+ "150.103\n"
+ "199.99\n"
+ "200\n"
+ "200.00\n"
+ "200.01\n"
+ "205.111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}