using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[01]?[0-9]{1,2}(?:\.[0-9]+)?$";
string input = @"0.0
50.123
150.103
199.99
200
200.00
200.01
205.111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}