// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[01]?[0-9]{1,2}(?:\.[0-9]+)?$").unwrap();
let string = "0.0
50.123
150.103
199.99
200
200.00
200.01
205.111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}