# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^[^-]{0,100}-[^-]{0,100})-/\n/gm;t' <<< "Part1-part2-part3-part4-part5"