re = /(?<=^[^-]{0,100}-[^-]{0,100})-/m
str = 'Part1-part2-part3-part4-part5'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result