$re = '/(?<=^[^-]{0,100}-[^-]{0,100})-/m';
$str = 'Part1-part2-part3-part4-part5';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;