#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\((\g<1>|\s)+\)|[^()\s]+)"
Local $sString = "24>n 0>t 1>a" & @CRLF & _
"(n-1" & @CRLF & _
" a+0" & @CRLF & _
" t<a>b+a" & @CRLF & _
" c<b>a<c" & @CRLF & _
" n?" & @CRLF & _
")" & @CRLF & _
"(t>@" & @CRLF & _
" (@>o)" & @CRLF & _
" 32>o" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")