package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((\g<1>|\s)+\)|[^()\s]+)`)
var str = `24>n 0>t 1>a
(n-1
a+0
t<a>b+a
c<b>a<c
n?
)
(t>@
(@>o)
32>o
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}