import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((\\g<1>|\\s)+\\)|[^()\\s]+)";
final String string = "24>n 0>t 1>a\n"
+ "(n-1\n"
+ " a+0\n"
+ " t<a>b+a\n"
+ " c<b>a<c\n"
+ " n?\n"
+ ")\n"
+ "(t>@\n"
+ " (@>o)\n"
+ " 32>o\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}