using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((\g<1>|\s)+\)|[^()\s]+)";
string input = @"24>n 0>t 1>a
(n-1
a+0
t<a>b+a
c<b>a<c
n?
)
(t>@
(@>o)
32>o
)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}