re = /(\((\g<1>|\s)+\)|[^()\s]+)/m
str = '24>n 0>t 1>a
(n-1
a+0
t<a>b+a
c<b>a<c
n?
)
(t>@
(@>o)
32>o
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end