$re = '/(\((\g<1>|\s)+\)|[^()\s]+)/m';
$str = '24>n 0>t 1>a
(n-1
a+0
t<a>b+a
c<b>a<c
n?
)
(t>@
(@>o)
32>o
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);