# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![A-z])[A-z]{4}(?![A-z])//gm;t' <<< "salut je m'appell adri et je suis chau"