const regex = /(?<![A-z])[A-z]{4}(?![A-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![A-z])[A-z]{4}(?![A-z])', 'gm')
const str = `salut je m'appell adri et je suis chau`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);