use strict;
my $str = 'salut je m\'appell adri et je suis chau';
my $regex = qr/(?<![A-z])[A-z]{4}(?![A-z])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";