using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![A-z])[A-z]{4}(?![A-z])";
string substitution = @"";
string input = @"salut je m'appell adri et je suis chau";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}