$re = '/(?<![A-z])[A-z]{4}(?![A-z])/m';
$str = 'salut je m\'appell adri et je suis chau';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;