re = /(?<![A-z])[A-z]{4}(?![A-z])/m
str = 'salut je m\'appell adri et je suis chau'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result