using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$";
string input = @"33 44 51 52 53 56
33 44 51 52 53 59
33 44 51 52 55 55
00 00 00 00 00 00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}