import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$";
final String string = "33 44 51 52 53 56 \n"
+ "33 44 51 52 53 59\n"
+ "33 44 51 52 55 55\n"
+ "00 00 00 00 00 00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}