$re = '/^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$/m';
$str = '33 44 51 52 53 56
33 44 51 52 53 59
33 44 51 52 55 55
00 00 00 00 00 00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);