use strict;
my $str = '33 44 51 52 53 56
33 44 51 52 53 59
33 44 51 52 55 55
00 00 00 00 00 00';
my $regex = qr/^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}