import re
regex = re.compile(r"^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$", flags=re.MULTILINE)
test_str = ("33 44 51 52 53 56 \n"
"33 44 51 52 53 59\n"
"33 44 51 52 55 55\n"
"00 00 00 00 00 00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")