const regex = /^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-F0-9]+)((\\.[A-Za-z0-9]+)*)$', '')
const str = `3051DFC10CBA8E5532404230727036.route123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}