import Foundation
let pattern = #"^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"3051DFC10CBA8E5532404230727036.route123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}