re = /^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$/
str = '3051DFC10CBA8E5532404230727036.route123'
# Print the match result
str.match(re) do |match|
puts match.to_s
end