#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*?([A-Z][a-z]*)\s+([A-Z][a-z]*)\s+(([A-Z])([A-Z])[0-9]{5}\5\4)\s+(\S+@\S+).*"
Local $sString = "Name list from PQP-97 system &%$ Bill Williams MK12345KM bwilliams01@msn.com ^ %20% " & @CRLF & _
"Bill Williams MK12345KM bwilliams01@msn.com" & @CRLF & _
"Fredericka Hanover GW22887WG freddie@verizon.net" & @CRLF & _
"Fredericka Hanover GW22887WG freddie@verizon.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")