re = /.*?([A-Z][a-z]*)\s+([A-Z][a-z]*)\s+(([A-Z])([A-Z])[0-9]{5}\5\4)\s+(\S+@\S+).*/
str = 'Name list from PQP-97 system &%$ Bill Williams MK12345KM bwilliams01@msn.com ^ %20%
Bill Williams MK12345KM bwilliams01@msn.com
Fredericka Hanover GW22887WG freddie@verizon.net
Fredericka Hanover GW22887WG freddie@verizon.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end