using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?([A-Z][a-z]*)\s+([A-Z][a-z]*)\s+(([A-Z])([A-Z])[0-9]{5}\5\4)\s+(\S+@\S+).*";
string input = @"Name list from PQP-97 system &%$ Bill Williams MK12345KM bwilliams01@msn.com ^ %20%
Bill Williams MK12345KM bwilliams01@msn.com
Fredericka Hanover GW22887WG freddie@verizon.net
Fredericka Hanover GW22887WG freddie@verizon.net";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}