import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?([A-Z][a-z]*)\\s+([A-Z][a-z]*)\\s+(([A-Z])([A-Z])[0-9]{5}\\5\\4)\\s+(\\S+@\\S+).*";
final String string = "Name list from PQP-97 system &%$ Bill Williams MK12345KM bwilliams01@msn.com ^ %20% \n"
+ "Bill Williams MK12345KM bwilliams01@msn.com\n"
+ "Fredericka Hanover GW22887WG freddie@verizon.net\n"
+ "Fredericka Hanover GW22887WG freddie@verizon.net";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}