const regex = /.*?([A-Z][a-z]*)\s+([A-Z][a-z]*)\s+(([A-Z])([A-Z])[0-9]{5}\5\4)\s+(\S+@\S+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?([A-Z][a-z]*)\\s+([A-Z][a-z]*)\\s+(([A-Z])([A-Z])[0-9]{5}\\5\\4)\\s+(\\S+@\\S+).*', 'g')
const str = `Name list from PQP-97 system &%\$ Bill Williams MK12345KM bwilliams01@msn.com ^ %20%
Bill Williams MK12345KM bwilliams01@msn.com
Fredericka Hanover GW22887WG freddie@verizon.net
Fredericka Hanover GW22887WG freddie@verizon.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}