import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:https?):\\/\\/)([a-z-A-Z0-9+&@#\\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\\/%=~_|$])[\\?]{1}([a-zA-Z0-9+&@#\\/%=~_|$,]+)";
final String string = "https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}