re = /(?:(?:https?):\/\/)([a-z-A-Z0-9+&@#\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\/%=~_|$])[\?]{1}([a-zA-Z0-9+&@#\/%=~_|$,]+)/
str = 'https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end