// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(?:https?):\/\/)([a-z-A-Z0-9+&@#\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\/%=~_|$])[\?]{1}([a-zA-Z0-9+&@#\/%=~_|$,]+)").unwrap();
let string = "https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}