const regex = new RegExp('(?:(?:https?):\\/\\/)([a-z-A-Z0-9+&@#\\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\\/%=~_|$])[\\?]{1}([a-zA-Z0-9+&@#\\/%=~_|$,]+)', '')
const str = `https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}