using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)^(?:\s*{{.*?}}|\s*\[\[.*?]])*\n?";
string substitution = @"";
string input = @"{{Ver desambig}}
{{Mais notas||ci|data=janeiro de 2013}}
{{Info/Taxonomia}}
[[Ficheiro:Pêra amarela.JPG|thumbnail|upright]]
A {{AO-pAO|pera|pêra}} é o fruto comestÃvel da pereira, uma [[árvore]] do.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}