re = /(?s)^(?:\s*{{.*?}}|\s*\[\[.*?]])*\n?/
str = '{{Ver desambig}}
{{Mais notas||ci|data=janeiro de 2013}}
{{Info/Taxonomia}}
[[Ficheiro:Pêra amarela.JPG|thumbnail|upright]]
A {{AO-pAO|pera|pêra}} é o fruto comestÃvel da pereira, uma [[árvore]] do.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result